Page Delivery Issues Observed
Postmortem

What happened?

Somebody/something(?) ran a Fastly cache check for one url: LetsEncrypt challenge. This lead to 429 responses which is unexpected.

What are we doing now?

A PR has been made to fix the response type to 403.

Posted Jun 09, 2021 - 07:20 UTC

Resolved
This incident has been resolved.
Posted Jun 07, 2021 - 16:54 UTC
Investigating
We are observing issues that are affecting page delivery for Project Helix customers. The issue is under active investigation and we are working with full effort to reach a speedy resolution.
Posted Jun 07, 2021 - 16:51 UTC