Page Delivery Issues Observed
Postmortem

Between 18:10 and 18:20 two of our internal monitors timed out. It is very unlikely that this incident was witnessed outside of our monitors.

Posted Jan 20, 2021 - 00:44 UTC

Resolved
This incident has been resolved.
Posted Jan 19, 2021 - 18:20 UTC
Investigating
We are observing issues that are affecting page delivery for Project Helix customers. The issue is under active investigation and we are working with full effort to reach a speedy resolution.
Posted Jan 19, 2021 - 18:10 UTC