Page Delivery Issues Observed
Postmortem

What happened?

Requests to a published site were repeatedly responded with a 404. After purging the CDN cache, the responses were correct again.

How did it happen?

The problem was caused by a backend service that was temporarily unavailable. Unfortunately it was internally handled as a 404, which got cached by the CDN. So even after the backend could render the site correctly again, it was still served as 404.

What are we doing now?

We will improve the internal error handling so that internal errors will not be cached.

Posted Sep 06, 2019 - 02:23 UTC

Resolved
This incident has been resolved.
Posted Sep 06, 2019 - 02:17 UTC
Investigating
We are observing issues that are affecting page delivery for Project Helix customers. The issue is under active investigation and we are working with full effort to reach a speedy resolution.
Posted Sep 06, 2019 - 01:50 UTC