Page Delivery Issues Observed
Postmortem

between 18:41 and 19:11 UTC we were experiencing significantly slower responses of our preview services that has resulted in intermittent timeouts for our customers during authoring and intermittent error messages displayed on public sites.

the root cause was a scheduled maintenance of one of our network providers and we was resolved with them reverting their configuration change after the problems were detected.

Posted Jan 14, 2021 - 15:25 UTC

Resolved
This incident has been resolved.
Posted Jan 13, 2021 - 19:34 UTC
Investigating
We are observing issues that are affecting page delivery for Project Helix customers. The issue is under active investigation and we are working with full effort to reach a speedy resolution.
Posted Jan 13, 2021 - 19:26 UTC