Page Delivery Issues Observed
Postmortem

between 17:12 UTC and 17:13 UTC two of our monitors (Seoul and Mumbai) reported failures to load the test payloads. It is highly unlikely that this was visible to the helix user base.

Posted Nov 12, 2020 - 23:02 UTC

Resolved
This incident has been resolved.
Posted Nov 10, 2020 - 17:13 UTC
Investigating
We are observing issues that are affecting page delivery for Project Helix customers. The issue is under active investigation and we are working with full effort to reach a speedy resolution.
Posted Nov 10, 2020 - 17:12 UTC