Page Delivery Issues Observed
Postmortem

For approximately 34 minutes we experienced downtime on our blog site. The issue was unavailability of a resource. The issue resolved once the resource was available again.

Posted Aug 31, 2020 - 18:00 UTC

Resolved
This incident has been resolved.
Posted Jul 10, 2020 - 17:58 UTC
Investigating
We are observing issues that are affecting page delivery for Project Helix customers. The issue is under active investigation and we are working with full effort to reach a speedy resolution.
Posted Jul 10, 2020 - 17:14 UTC