Page Delivery Issues Observed
Postmortem

On 16:12 UTC a monitor fired an alarm that the blog.adobe.com homepage no longer contained its initial content. It turned out that a request for the latest 256 blog articles returned a 502 (Bad Gateway) status code. Further investigation revealed that some minutes before, the outer CDN cache for those blog articles had been purged, and even though a immediate refetch should had refilled the cache entry, a subsequent request for those articles returned a 502 for the first time, which was cached.

That bad cache entry was purged again, the article list was successfully requested, and its valid response was cached.

As said above, we have an immediate refetch in our purge logic, which should prevent such issues to occur, so we’ll keep observing whether it operates correctly in the future.

Posted Jan 15, 2021 - 16:30 UTC

Resolved
This incident has been resolved.
Posted Jan 14, 2021 - 16:25 UTC
Investigating
We are observing issues that are affecting page delivery for Project Helix customers. The issue is under active investigation and we are working with full effort to reach a speedy resolution.
Posted Jan 14, 2021 - 16:10 UTC