Page Delivery Issues Observed
Postmortem

between 02:29 UTC and 04:29 UTC a single customer page was served as a 404 instead of a 200 for a small amount visitors. rthe problem was remedied quickly and the root cause was addressed.

Posted Apr 21, 2021 - 22:38 UTC

Resolved
This incident has been resolved.
Posted Apr 17, 2021 - 02:40 UTC
Investigating
We are observing issues that are affecting page delivery for Project Helix customers. The issue is under active investigation and we are working with full effort to reach a speedy resolution.
Posted Apr 17, 2021 - 02:29 UTC